Karl baut eine Burg

Karl soll eine Burg bauen. Dabei soll die Burg so groß wie die Welt werden. 

Video (Youtube) 

Lösung: Karl wirft mehrere Steine auf einmal
Anweisung Umdrehen
  Schnell
  RechtsDrehen
  RechtsDrehen
  Langsam
*Anweisung

wiederhole 8 mal
  Schnell
  wiederhole solange NichtIstWand
    Hinlegen
    Schritt
  *wiederhole
  LinksDrehen
  Langsam
*wiederhole

wiederhole 4 mal
  Schnell
  wiederhole solange NichtIstWand
    Schritt
  *wiederhole

  LinksDrehen
  Schritt
  LinksDrehen
  Hinlegen(2)
  wiederhole 12 mal
    Hinlegen
    Schritt
    LinksDrehen
  *wiederhole
  Langsam
  RechtsDrehen
  Hinlegen(2)
  Schritt
  Hinlegen(1)
  Schritt
  Umdrehen
  Aufheben(2)
  Umdrehen
  Schritt
  Umdrehen
  Aufheben(1)
  Umdrehen
*wiederhole
LinksDrehen
Hinlegen
Schritt(2)
umdrehen
Aufheben
umdrehen
Schritt
RechtsDrehen
Lösung: Karl wirft Steine nur eine Ebene hinunter

2. Lösung

Anweisung Umdrehen
  Schnell
  RechtsDrehen
  RechtsDrehen
  Langsam
*Anweisung

wiederhole 8 mal
  Schnell
  wiederhole solange NichtIstWand
    Hinlegen
    Schritt
  *wiederhole
  Umdrehen
  Schritt
  RechtsDrehen
  Hinlegen
  RechtsDrehen
  Schritt
  LinksDrehen
  Langsam
*wiederhole

wiederhole 4 mal
  wiederhole solange NichtIstWand
    Schritt
  *wiederhole
  LinksDrehen
  schnell
  wiederhole 8 mal
    Hinlegen
    Schritt
    LinksDrehen
  *wiederhole
  langsam
  Schritt
  Hinlegen
  Schritt
  Schritt
  Umdrehen
  Aufheben
  Umdrehen
*wiederhole

LinksDrehen
Hinlegen
Schritt
Schritt
Umdrehen
Aufheben
Umdrehen
Schritt(3)
RechtsDrehen