Projektidee

In diesem Projekt schreibt Karl Zahlen. Anschließend werden die Zahlen alw verschieden hohe Türme dargestellt.

Damit sollte er in der Lage sein, zwei Zahlen zu addieren und anschließend diese als Zahl zu schreiben. 

Aufgabe:

Karl lernt Zahlen zu schreiben. Programmiere für jede Zahl eine eigene Anweisung.

Achte darauf, dass Karl bei jeder Zahl immer in der gleichen Ausgangsposition stehen soll!

Schülerergebnis

Ergebnisse meiner Schüler

Anweisung umdrehen
  LinksDrehen
  LinksDrehen
*Anweisung

Anweisung Eins
  LinksDrehen
  Schritt
  RechtsDrehen
  Schritt(2)
  Hinlegen
  LinksDrehen
  Hinlegen
  Schritt
  LinksDrehen
  Schritt
  RechtsDrehen
  Hinlegen
  Schritt
  LinksDrehen
  Schritt
  RechtsDrehen
  Hinlegen
  Schritt
  RechtsDrehen
  wiederhole 9 mal Hinlegen
    Schritt *wiederhole
    RechtsDrehen
    Schritt(4)
    RechtsDrehen
    Schritt(4)
    Hinlegen
    RechtsDrehen
    Schritt(7)
    LinksDrehen
    Schritt(5)
    umdrehen
*Anweisung

Anweisung Zwei
   Hinlegen
   LinksDrehen
   Hinlegen
   Schritt
   Hinlegen
   Schritt
   Hinlegen
   Schritt(2)
   RechtsDrehen
   Hinlegen
   wiederhole 2 mal
     Schritt
     Hinlegen *wiederhole
     Schritt(2)
     wiederhole 3 mal
       RechtsDrehen
       Hinlegen
       Schritt
       LinksDrehen
       Schritt
     *wiederhole
     RechtsDrehen
     Hinlegen
     Schritt
     LinksDrehen
     Hinlegen
     Schritt
     Hinlegen
     Schritt
     LinksDrehen
     wiederhole 4 mal
       Hinlegen
       Schritt      
     *wiederhole
     Schritt (3)
     LinksDrehen
     Schritt  (9)
     umdrehen
*Anweisung

Anweisung drei
   LinksDrehen
   Schritt
   umdrehen
   Hinlegen
   Schritt
   umdrehen
   wiederhole 3 mal
     Hinlegen
     Schritt
   *wiederhole
   Schritt
   RechtsDrehen
   Hinlegen
   Schritt
   Hinlegen
   Schritt
   Hinlegen
   Schritt (2)
   RechtsDrehen
   wiederhole 2 mal
     Hinlegen
     Schritt
   *wiederhole
   Hinlegen
   umdrehen
   Schritt (2)
   RechtsDrehen
   wiederhole 4 mal
     Hinlegen
     Schritt
   *wiederhole
   Schritt
   RechtsDrehen
   wiederhole 4 mal
     Hinlegen
     Schritt
   *wiederhole
   umdrehen
   Schritt(7)
   LinksDrehen
   Schritt (9)
   umdrehen
*Anweisung

Anweisung vier
   Schritt (9)
   LinksDrehen
   Schritt (1)
   Hinlegen
   Schritt
   LinksDrehen
   wiederhole 6 mal
     Hinlegen
     Schritt
   *wiederhole
   umdrehen
   Schritt
   LinksDrehen
   wiederhole 2 mal
     Hinlegen
     Schritt
   *wiederhole
   umdrehen
   Schritt(2)
   wiederhole 2 mal
    Hinlegen
    Schritt
   *wiederhole
   RechtsDrehen
   wiederhole 4 mal
     Hinlegen
     Schritt
   *wiederhole
   RechtsDrehen
   Schritt(7)
   RechtsDrehen
*Anweisung

Anweisung Lege1unten
   Hinlegen
   Schritt
*Anweisung

Anweisung fuenf
  wiederhole 4 mal
    Lege1unten
  *wiederhole
  wiederhole 2 mal
     Schritt
     LinksDrehen
  *wiederhole
  wiederhole 4 mal
     Schritt
  *wiederhole
  Hinlegen
  Schritt
  RechtsDrehen
  wiederhole 3 mal
    Lege1unten
  *wiederhole
  wiederhole 2 mal
    LinksDrehen
  *wiederhole
  wiederhole 4 mal
    Schritt
  *wiederhole
    LinksDrehen
   wiederhole 4 mal
    Schritt
   *wiederhole
    LinksDrehen
   wiederhole 3 mal
    Lege1unten
   *wiederhole
   Schritt
   RechtsDrehen
   wiederhole 4 mal
    Lege1unten
   *wiederhole
    Schritt
   RechtsDrehen
   wiederhole 3 mal
     Lege1unten
   *wiederhole
   Schritt
   RechtsDrehen
   Hinlegen
   wiederhole 9 mal
     Schritt
   *wiederhole
    RechtsDrehen
    wiederhole 7 mal
     Schritt
   *wiederhole
     RechtsDrehen
   *Anweisung





      Anweisung sechs

        wiederhole 8 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen

        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 4 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        RechtsDrehen
        wiederhole 3 mal
          Schritt
        *wiederhole
        Hinlegen
        Schritt
        RechtsDrehen
        wiederhole 3 mal
          Hinlegen Schritt
        *wiederhole
        Schritt(3)
        RechtsDrehen

      *Anweisung


      Anweisung sieben
        LinksDrehen
        Schritt
        umdrehen
        Hinlegen
        Schritt
        umdrehen

        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        RechtsDrehen
        wiederhole 9 mal
          Hinlegen
          Schritt
        *wiederhole
        umdrehen
        Schritt(5)
        RechtsDrehen
        Hinlegen
        umdrehen
        wiederhole 2 mal
          Hinlegen
          Schritt
        *wiederhole
        umdrehen
        Schritt(6)
        LinksDrehen
        Schritt(4)
        umdrehen
      *Anweisung

      Anweisung gerade8
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        wiederhole 4 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
      *Anweisung

      Anweisung wagrecht8
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
      *Anweisung

      Anweisung  acht


        gerade8

        wagrecht8
        Schritt(9)
        umdrehen
        gerade8
        LinksDrehen
        Schritt(9)
        LinksDrehen
        wagrecht8
        Schritt(4)
        LinksDrehen
        wagrecht8
        Schritt(4)
        RechtsDrehen
        Schritt(3)
        RechtsDrehen
      *Anweisung


      Anweisung neun
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 4 mal
          Hinlegen
          Schritt
        *wiederhole
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        LinksDrehen
        wiederhole 8 mal
          Schritt
        *wiederhole
        Hinlegen
        Schritt
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        LinksDrehen
        wiederhole 4 mal
          Hinlegen
          Schritt
        *wiederhole
        wiederhole 5 mal
          Schritt
        *wiederhole
        RechtsDrehen
        Schritt(3)
        RechtsDrehen
      *Anweisung

      Anweisung null
        wiederhole 8 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 8 mal
          Hinlegen
          Schritt
        *wiederhole
        Schritt
        LinksDrehen
        wiederhole 3 mal
          Hinlegen
          Schritt
        *wiederhole
        umdrehen
        wiederhole 6 mal
          Schritt
        *wiederhole
        RechtsDrehen
      *Anweisung

      eins
      zwei
      drei
      vier
      fuenf
      sechs
      sieben
      acht
      neun
      null

Zurück